#1 21 Jul 2009 15:08

Simon Sheppard
Super Administrator
Registered: 27 Aug 2005
Posts: 900
Website

WWW prefix for URLs

You may notice that I have changed the default URLs from WWW.SS64.com to just SS64.com, and the same for the discussion board.

With the advent of things like Twitter, it makes sense to keep the urls as short as possible.

The old style URLs still work so hopefully this won't break anything.

Offline

#2 25 Jul 2009 16:34

bluesxman
Member
From: UK
Registered: 29 Dec 2006
Posts: 1,036

Re: WWW prefix for URLs

Dunno if it's related, but I now don't seem to be able to maintain my forum logon between browser sessions ... is there something wanky going on with the cookies?


cmd | *sh | Ruby | Chef | Puppet | PowerShell | AutoIT3

Offline

#3 27 Jul 2009 21:54

Simon Sheppard
Super Administrator
Registered: 27 Aug 2005
Posts: 900
Website

Re: WWW prefix for URLs

^ very probably - if you delete the cookie and login again that should fix it.

Offline

#4 28 Jul 2009 15:54

bluesxman
Member
From: UK
Registered: 29 Dec 2006
Posts: 1,036

Re: WWW prefix for URLs

Yeah I tried that on the first or second instance of the problem -- no dice!  I just had to log in again to reply, in fact.

Interestingly, now that I've (just) had another look at the properties of the cookie I see it says "Expires: End of Session" -- and I've got no "Keep me signed in" option at the login page.


cmd | *sh | Ruby | Chef | Puppet | PowerShell | AutoIT3

Offline

#5 28 Jul 2009 18:14

Simon Sheppard
Super Administrator
Registered: 27 Aug 2005
Posts: 900
Website

Re: WWW prefix for URLs

Do you have a tick under Profile > Privacy
  "Save username and password between visits."

Offline

#6 01 Aug 2009 12:37

bluesxman
Member
From: UK
Registered: 29 Dec 2006
Posts: 1,036

Re: WWW prefix for URLs

Aye, that's already ticked -- I certainly never used to have a problem staying signed in!


cmd | *sh | Ruby | Chef | Puppet | PowerShell | AutoIT3

Offline

#7 01 Aug 2009 12:42

Simon Sheppard
Super Administrator
Registered: 27 Aug 2005
Posts: 900
Website

Re: WWW prefix for URLs

Is your browser caching the username/password?

Maybe try going to the login page, shift delete the username/password and then re-enter it

Offline

#8 01 Aug 2009 12:54

bluesxman
Member
From: UK
Registered: 29 Dec 2006
Posts: 1,036

Re: WWW prefix for URLs

Yes FF is caching my login.  I've just tried removing it via the saved passwords dialog -- no change.   And the cookie is still saying "end of session" in the expiry field. neutral

EDIT: Just tried creating a shiny new profile in FF and the problem has gone away.  WTF?

Last edited by bluesxman (01 Aug 2009 12:56)


cmd | *sh | Ruby | Chef | Puppet | PowerShell | AutoIT3

Offline

#9 01 Aug 2009 13:07

Simon Sheppard
Super Administrator
Registered: 27 Aug 2005
Posts: 900
Website

Re: WWW prefix for URLs

I'll bet this was the 'cookies.sqlite' file:

Sometimes removing the cookies in the Cookie Manager is not sufficient and you need to delete the file that stores cookies in your Firefox profile folder ("cookies.sqlite" in Firefox 3, "cookies.txt" in Firefox 2 or below).
http://kb.mozillazine.org/Cookies

Offline

#10 01 Aug 2009 13:30

bluesxman
Member
From: UK
Registered: 29 Dec 2006
Posts: 1,036

Re: WWW prefix for URLs

That didn't work.

However, adding "ss64.org" to cookies exceptions in "always allow" mode seems to have made the difference.  All very odd because I never had to add the site in the past and I have "Accept cookies" enabled.  Anyway, problem solved, even if I don't understand why it was being an ass in the first place.


cmd | *sh | Ruby | Chef | Puppet | PowerShell | AutoIT3

Offline

Board footer

Powered by FluxBB